iManage: Why Can't I Delete a File or Folder?

Creation date: 25/09/2025 11:14    Updated: 25/09/2025 14:39   imanage

You may find that the option to delete a document, folder, or workspace is sometimes unavailable in iManage.


Cause


The security settings in iManage are designed to protect content from accidental deletion. As a rule, only the original creator (Owner) of an item has the permission to delete it.

If you did not create the item yourself, you will not have the rights to remove it.


Resolution


To have an item deleted, you must contact the person who owns it. You can easily check who the owner is within iManage.

  1. Select the Item: Click on the file or folder you wish to delete.

  2. View Properties: Look at the item's properties panel (this usually appears on the right-hand side of the screen).

  3. Identify the Owner: Scroll down in the properties panel until you see the Owner field, as shown below. This field will display the name of the person you need to contact to request the deletion.

Simply contact the person listed as the Owner and ask them to delete the item for you.